DELL Laptop // IRQ Conflict // Maestro3 // !ACPI/SAFE MODE Failure

vermaden vermaden at interia.pl
Sat Feb 17 13:00:34 UTC 2007


My buddy does not know english very well so I am posting his problem with Dell Latitude Laptop:

The problem is that he has crappy sound with his Maestro3 Sound Card.

error messages:
pcm0:play:1:dsp0.1: play interrupt timeout channel dead

% vmstat -i # GENERIC 6.2
interrupt                          total       rate 
irq0: clk                         151683        991 
irq1: atkbd0                         119          0 
irq5: pcm0                           469          3 
irq6: fdc0                             7          0 
irq7: ppc0                             1          0 
irq8: rtc                          19427        126 
irq10: cbb0 cbb1+*                  1444          9 
irq11: nvidia0                      7564         49 
irq12: psm0                         7089         46 
irq14: ata0                         7968         52 
Total                             195771       1279

this setup in /boot/loader.conf also did not helped:

snd_maestro3_load="YES"
hint.cbb.0.disabled="1" 
hint.cbb.1.disabled="1" 
hint.pccard.0.disabled="1" 
hint.pccard.1.disabled="1" 
hint.cardbus.0.disabled="1" 
hint.cardbus.1.disabled="1"

after removing pcimcia support from kernel:
% vmstat -i
interrupt                          total       rate 
irq0: clk                         206211        991 
irq1: atkbd0                         512          2 
irq5: pcm0                          1474          7 
irq6: fdc0                             7          0 
irq7: ppc0                             1          0 
irq8: rtc                          26408        126 
irq10: xl0 fwohci+                  4748         22 
irq11: nvidia0                      8684         41 
irq12: psm0                           36          0 
irq14: ata0                         7999         38 
Total                             256080       1231

after removing firewire from kernel:
% vmstat -i
interrupt                          total       rate 
irq0: clk                         247221        992 
irq1: atkbd0                         413          1 
irq5: pcm0                           509          2 
irq6: fdc0                             7          0 
irq7: ppc0                             1          0 
irq8: rtc                          31659        127 
irq10: xl0 uhci0                    6701         26 
irq11: nvidia0                     12729         51 
irq12: psm0                            6          0 
irq14: ata0                         9677         38 
Total                             308923       1240

no IRQ conflicts at this time, but the glitchy sound still is the problem.

setting hint.pcm.0.hwvol_config="0" in /boot/loader.conf also did not helped.

hardware:

Dell Latitude C810 BIOS A12

P3 Tualatin Mobile 1000/733 133MHz FSB 
2x256 SDRAM 133MHz Kingston 
Intel 815e/ep 
Geforce2Go 16MB DDR 
ESS Maestro 3 
3Com 56k V.90Mini PCI Modem/ 3Com Ethernet 10/100 
Kontroler IEEE 1394 Texas Instruments 
CardBUS Texas Instruments PCI-4451 
Dysk Toshiba MK2018GAS 
CD SAMSUNG SN-124

kernel was GENERIC 6.2[later with remover pcimcia and firewire] also 7.0/5.4 GENERIC tried without success.

here is some other info:

% pciconf -lv
hostb0 at pci0:0:0:        class=0x060000 card=0x00000000 chip=0x11308086 rev=0x04 
hdr=0x00 
    vendor   = 'Intel Corporation' 
    device   = '82815/EM/EP/P 815/EM/EP/P (Solano) Host to I/O Hub Bridge' 
    class    = bridge 
    subclass = HOST-PCI 
pcib1 at pci0:1:0: class=0x060400 card=0x00000000 chip=0x11318086 rev=0x04 hdr=0x01 
    vendor   = 'Intel Corporation' 
    device   = '82815/EM/EP/P 815/EM/EP/P (Solano) PCI to AGP Bridge' 
    class    = bridge 
    subclass = PCI-PCI 
pcib2 at pci0:30:0:        class=0x060400 card=0x00000000 chip=0x24488086 rev=0x03 
hdr=0x01 
    vendor   = 'Intel Corporation' 
    device   = '82801BAM/CAM/DBM (ICH2-M/3-M/4-M) Hub Interface to PCI Bridge' 
    class    = bridge 
    subclass = PCI-PCI 
isab0 at pci0:31:0:        class=0x060100 card=0x00000000 chip=0x244c8086 rev=0x03 
hdr=0x00 
    vendor   = 'Intel Corporation' 
    device   = '82801BAM (ICH2-M) LPC Interface Controller' 
    class    = bridge 
    subclass = PCI-ISA 
atapci0 at pci0:31:1:      class=0x010180 card=0x45418086 chip=0x244a8086 rev=0x03 
hdr=0x00 
    vendor   = 'Intel Corporation' 
    device   = '82801BAM (ICH2-M) UltraATA/100 IDE Controller' 
    class    = mass storage 
    subclass = ATA 
uhci0 at pci0:31:2:        class=0x0c0300 card=0x45418086 chip=0x24428086 rev=0x03 
hdr=0x00 
    vendor   = 'Intel Corporation' 
    device   = '82801BA/BAM (ICH2/ICH2-M) USB Universal Host Controller' 
    class    = serial bus 
    subclass = USB 
none0 at pci1:0:0: class=0x030000 card=0x00e51028 chip=0x011210de rev=0xb2 hdr=0x00 
    vendor   = 'NVIDIA Corporation' 
    device   = 'NV11 GeForce2 Go / MX Ultra' 
    class    = display 
    subclass = VGA 
none1 at pci2:3:0: class=0x040100 card=0x00e51028 chip=0x1998125d rev=0x10 hdr=0x00 
    vendor   = 'ESS Technology' 
    device   = 'ES1980 Maestro-3 PCI Audio Accelerator' 
    class    = multimedia 
    subclass = audio 
xl0 at pci2:6:0:   class=0x020000 card=0x645610b7 chip=0x605510b7 rev=0x10 hdr=0x00 
    vendor   = '3COM Corp, Networking Division' 
    device   = '3C556 10/100 Mini PCI Fast Ethernet Adapter' 
    class    = network 
    subclass = ethernet 
none2 at pci2:6:1: class=0x078000 card=0x615b10b7 chip=0x100710b7 rev=0x10 hdr=0x00 
    vendor   = '3COM Corp, Networking Division' 
    device   = '3C556 V.90 Mini-PCI Modem' 
    class    = simple comms 
cbb0 at pci2:15:0: class=0x060700 card=0x00e51028 chip=0xac42104c rev=0x00 hdr=0x02 
    vendor   = 'Texas Instruments (TI)' 
    device   = 'PCI4451 PC card CardBus Controller' 
    class    = bridge 
    subclass = PCI-CardBus 
cbb1 at pci2:15:1: class=0x060700 card=0x00e51028 chip=0xac42104c rev=0x00 hdr=0x02 
    vendor   = 'Texas Instruments (TI)' 
    device   = 'PCI4451 PC card CardBus Controller' 
    class    = bridge 
    subclass = PCI-CardBus 
fwohci0 at pci2:15:2:      class=0x0c0010 card=0x00e51028 chip=0x8027104c rev=0x00 
hdr=0x00 
    vendor   = 'Texas Instruments (TI)' 
    device   = 'PCI4451 OHCI-Lynx IEEE-1394 FireWire Adapter' 
    class    = serial bus 
    subclass = FireWire

% vmstat -i # from GENERIC FreeBSD 7.0-CURRENT 200702 snapshot
interrupt                          total       rate 
irq0: clk                        1713674        999 
irq1: atkbd0                        1085          0 
irq5: pcm0                         11217          6 
irq6: fdc0                             7          0 
irq7: ppc0                             1          0 
irq8: rtc                         219463        127 
irq10: cbb0 cbb1+*                 43281         25 
irq12: psm0                           39          0 
irq14: ata0                        39936         23 
Total                            2028703       1182

the other problem is also that booting in SAFE MODE or with ACPI DISABLED the laptop is not booting and bootloader is showing that it cant load the kernel.

my knowledge ends here...

thanks for any help and hints.

----------------------------------------------------------------------
Ustawiaj rekordy DNS dla swojej domeny >> 
http://link.interia.pl/f1a1a



More information about the freebsd-bugs mailing list