misc/93786: almost fried my pcdleluxe system??couldnt get it to reboot

david davidrussell at bellnet.ca
Fri Feb 24 10:30:10 PST 2006


The following reply was made to PR misc/93786; it has been noted by GNATS.

From: david <davidrussell at bellnet.ca>
To: davidrussell at bellnet.ca, bug-followup at FreeBSD.org
Cc:  
Subject: Re: misc/93786: almost fried my pcdleluxe system??couldnt get it
	to reboot
Date: Fri, 24 Feb 2006 13:28:15 -0500

 here's the situation,
 I purchased a PC-DL-DELUXE
 IN SHORT I SEARCHED THE NET FOR SERVER BOARD THAT WASN'T
 WINBONEDED--ARHG!this board comes with a lot of windows drivers,and a
 version of openhost server program,that i couldn't get to function
 100/%.asus boards dont say that they are windoewd,but they do give lots
 of extra hardware that my supermicro board doesnt come with.and will run
 on linux.
 the raid is a bios raid but also can be a raid card(didnt have)
 and last year this board was advanced over the oses available that could
 properly handle this system,and suse9.1 doesnt like a bios raid!
 
   Anyways to use the raid setup on this board one must pay close
 attention to the setup in bios as this board can be setup up in several
 formats,with raids without raids, ide mode, raid mode, ide mode with
 raid ,sata only ,auto mode is for non windows use but it doesnt allow
 proper setup when formatting,and "sata only" locks you out from pata
 hdds,and if you dont notice that the promise raid controller has two
 mode functions)ide mode or raid mode or sata raid mode(3) as well as
 what sata plug one puts the sata drive on you will never see the(and i
 only had one sata installed after other hdds)sata drive show up on boot
 screen,but it will show up if one has setup it up in promise raid
 mode,provided the sata promise program is "LOADED" BEFORE OS.note:
 one should install windox with all drivers as this will install promise
 controller software,even after windoes is removed,it should be there,
 also format your  bios with the lastest,make sure you get rid of factory
 installed bios as its (N)ot,(F)eeling,(G)ood compared to latest.
 ok so now i have it all together have installed .net trial edition,every
 thing works fine with all the windows based drivers,except it doesn,t
 show my 2 250 gigabyte drives on the sata,took box to dealer,after no go
 at dealers,on way out door someone said to me what i'd been saying all
 along,where's my raid ,why cant i access them .
 id had some problems installing video card,board had a bent pin,so i
 think board is wiggy,note to asus:r&r program sux sewer sludge 160.00 us
 $ round trip.a new board can be had for 249.00cndn.
 anyways,techy on smoke break outside store spoke to me says"we cannot
 access the promise raid drives at all,we even installed our master drive
 and xp/1,note xp/2 does after a year of frustration with this board,your
 waiting for the freebsd part,im getting to it.
 I put the system together myself november 3/05,and im not thumbs!at all!
 so-board is up and running with 2  Western digital 160 gig hdd on master
 controller,or 1 on master and one on sata i probably had both ways going
 cdrom on secondary,i might of had one 160 gig on sata controller at the
 time,as i did try my luck at the raid program.
 i had used several operating systems in  search for a reliable server
 driver os,which i was told Freebsd was best for this.
 i had down loaded freebsd 5.3 stable.brnt it 2 a cd,dropt it in and
 rebooted.nada nada nada,it went through boot screen then rebooted,boot
 screen ,then rebooted,repeatedly.
 so thouhgt board was still nfg,yet it will boot a fedora install and
 others,but certain downloaded os burnt to a cd do nor permit installing
 at all.freebs is one!
 so last august i bought 2 new western digital 250 gig hard
 drive,formatted them on the sata promise raid controller,then later i
 went out and bouhgt a western digital sata drive and installed that.
 now the fun begins:
 i again tried freebs with all drives formatted with western digital
 hardrive format and overlay program,dealer thinks i shuoldn't use it,my
 system won't go past 34-6 gigs without hardrive overlay installed as it
 is only on furst and last portion of drive according to my research.
 note yes i had to research this on net.asus pc dl deluxe server
 board,may support newer drives without this installed,the wd is
 supposedely preformatted as a dos 32 platform,but mine weren't,maybe cuz
 were in canada,or us shipppng laws?had to format all drives with wd
 format program as it sets them up in bios.even if linuxs format them
 again,one should use this program,correct me if i'm wrong,also after
 several variuos installs,one should zero format,my dealer said to use a
 maxtor program,bad idea,had much problem geting system to boot ,and
 after i had formatted with maxtors program i tried a freebs
 install,nothing,not even a boot screen.
 spent 2 days just trying to recover system from complete failure,
 pulled cmos pin at 20 times that day.
 after reformatting and getting system to restart note dont use the safe
 settup in cmos as it locks up board if it the original factory cmos.
 so after i had installed all these drives 5 western digitals in all,
 i wanted freebsd installed.
 it wouldnt even boot last august with only 2 160s and 2 250 on raid.
 and after several attempts the boot loader is the first thing that runs
 then all stops.your bootloader causes a lot of problems,on intel based
 chipset board as i setup freebds on my 2002 intel board,last august as
 well,with absolute 0 as the boot partition.trying to reformat is almost
 imposible.
 well after several attempts my asus machine locks up.new machine
  shouldn't but being a high end system i had to be patient!
 freebsd caused me to pull the cmos pin so many time i contemplated
 setting up a dip switch on a panel!but my server shouldn't be doing this
 i cmosed it abut 20 times then i had to disconnect all the
 hardives,format my cmos,reinstall all my drives,installed fedora core
 went on line and researched,ncq,well last years drives have what the
 packaging desribes as"command modeule transfer or queing"a forerunner of
 the term ncq,as each drive is interconnected to the cmos with a cmos of
 its own,and when formatted with certain os,such as linux,which does not
 use the cmos the same way as windows,but all in all,each drive had a
 portion of your bootloader installed,i suspect,and my machine would not
 boot at all until all hardrives were removed,then i found my cmos buggy
 so i had to flash it with a newer version.
 anyways freebsd helped really screw up my asus pc-dl deluxe server board
 to the point i thought it was totally fried,i went to bed that night
 with hopes of a fresh start the next day.I had to flash this fuchin
 board at least ten times with asus flash cmos.
 finally.it runs again.after i had installed the drives again ,it would
 not boot,oh shit!,soo i removed the sata drives,hit reboot,nada,just
 hung on bios page.
 the freebsd bootloader had gotten into all my drives cmos,and if u tell
 me these new drives dont have their  own cmos or resident
 memory,according to my research they do and this is were your bootloader
 parks part of its program i suspect.
 finally i removed all but one drive,formatted it reinstalled my other
 drives,only to go round again for another whole day,so i reverse
 formtted the drives as well as resetting jumpers on master slave to m
 and from cs.and so forth,remember to put dips back were they were or you
 will have problems with format,plus you must use freebsd format program
 to delete itself or if you use freedos or fdisk over the freebsd shadow
 dos partition that freebsd implements,you will find you have made
 another sahodow dos partiton over top of freebsd,and any other linux
 partition will try to reside on top and things go awry,then one "MUST'
 REVERSVE THE FORMATS IN SEQUENCE WITH THE PROGRAMS USED UNTIL YOPU
 ARRIVE AT THE BEGINNIG,THEN DELETE FREEBSD WITH ITS OWN PARTITION,REBOOT
 AFTER THAT AND USE YOUR HDD FORMAT AT LEVEL ZERO.AND CROSS YOUR
 FINGERS,THE FREEBSD FORMAT HASNT DESTROYED YOUR DISK!!!
 IT MAY BE THE CAUSE OF LOSING A MAXTOR THIS WAY!
 AND I DID LOOSE A NEW WESTERN DIGITAL 2 MONTHS OLD,IM SERIOUSLY THINKING
 ABOUT A WORN DRIVE AND RAM BASED SYSTEM!
 anyways the freebsd bootloader seems to be a major problem with a
 multiplex system,perhaps im wrong.but with newer drives installed last
 summer,post ncq,i didnt get the right answers,so heres what i found out,
 to get freebsd to setup on as Asus pc-dl-deluxe server board,
 1:use the most stable or lastest cmos program,i used 9 but it is
 suggested 8 is more stable,apparently once you have jumped up from
 factory to cmos 7,then 8,then 9 it does not seem to work to well when
 down flashi9ng from 9 to the factory disc program,but that was the only
 way i could get board to run,and then u must refLash with the highest
 cmos again as my cmos had shadow versions of two diferent levels until i
 reflashed back to 9.
 2:to install freebs remove all drives except your master hardrive.
 install,shut down install other hardrives,reboot you will notice the
 report on post shows raid.
 i did not get much luck with gnome all i got was fvwm,:sux!
 and if version  6 did the promise raid controller,i dont recall.
 in the end the conclusion i had after spending days with your install
 program which i think needs a complete rewrite,your package mangement
 would be better if you went to debians style apt!to long to pick
 through,and if you make a mistake it doesn't allow that without a
 complete reboot and reformat.i found this the easiest solution!
 in short dont try to run freebsd on an asus board,or you'll go mad!!!
 trying to recover cmos hardives and your marbles!
 one more tripo to dealer he supplied me with windoze xp/service
 pack2this fall!
 well helelo raid drives,note fedora core 2 preinstall the sata raid
 drivers but it doesnt even show them in format program,but the fedora
 core 4 fund all my drives,allowed me to format them and now,my machine
 appears to be working just fine!
 I had managed to get freebsd version 4.4 running on another pc 3 years
 ago but the video setup suxxxxxxxxxxxxxxxxxxxxxxxxx,but once setup,i
 reaally liked the graphics and backgounds.
 perhaps a totall rewrite of 3 areas in your program would greatly
 improve things!that your bootloader "doesnt ever reside in cylinder
 zero"that the setup program not take 4 hours to install,and a better
 package management system be implemented,and also that your partioning
 system can recognize high end systems with a bios raid,multiple
 discs,and command module queing or transfer or ncq.
 for all the efforts to install freebsd on my asus server,frying
 $$6000.xx bux worth of system isnt worth the risk,so whats so great
 about freebsd?
 apparenltly your system is supposed to be tops in a server based setup.
 i did get xterm working,but only fvwm no kde no gnome,and only if one
 drive is installed during setup,kind of defeats the purpose of a server,
 dont you think??????
 id like to see it running,but not until you get the bugs out,on this
 machine.note to dealers wd requires the hardrive overlay or the cmos
 wont recognize superdrives.and remember the cmos is now spread thru ncq
 memory onboard each drive.and must be reformatted individually on the
 master controller.from my experience!
 i argued with dealer they only think they know it all!do your research!
 if you can suggest a freebsd install that wouldnt put me thru all this
 id like to try it,any sugestions.
 ps why is it that your boot disc wont even run an install 0n my
 sis desktop (01)says bios to old!)system,another os Xoslinux4 wont boot
 on my asus server but will boot on my sis desktop,this os is similar to
 fedora core,which they admit is redhats server program!,but were on
 about freebullshit arnt we!
 got any solutions.other than a new board!?!?!!
 my next choice of boards more than likely will be several lantastics in
 a tub box!will freebds work in a parrellell server enviroment?
 david at pcwurx.com
 
 


More information about the freebsd-bugs mailing list