if_iwi on Thinkpad T43

Nathan Lay nslay at comcast.net
Wed Feb 15 22:33:02 PST 2006

I've encountered a strange problem with the IPW 2915ABG adapter on a 
Thinkpad T43.  ACPI thinks the card is turned on,
dev.acpi_ibm.0.wlan: 1
yet, the driver isn't even loaded.
Now, if I load the driver it attaches just fine
iwi0: <Intel(R) PRO/Wireless 2915ABG> mem 0xa8401000-0xa8401fff irq 11 
at device 2.0 on pci4
iwi0: Ethernet address: 00:13:ce:b7:ea:87
Now, without even loading the firmware
LIGHTBULB# iwicontrol iwi0 -r
Radio is ON
It still thinks it is on.  After loading the firmware using 'ifconfig 
iwi0 up' or 'dhclient iwi0' has no effect.

Does anyone have any idea why either ACPI thinks the card is already on, 
or why the system turns the card on at boot?
I tried a number of things with the BIOS and I also tried a number of 
things with the kernel config.  Is this a bug?  If so, is it a bug with 
if_iwi or ACPI?

Here is my uname:
Feb 13 20:59:21 EST 2006     
root at LIGHTBULB.LOCAL:/usr/obj/usr/src/sys/LIGHTBULB  i386

If anyone has any idea whats going on, please let me know.

Best Regards,
Nathan Lay

More information about the freebsd-bugs mailing list