misc/106091: Keyboard disabled at mountroot> prompt

Ruslan Ermilov ru at FreeBSD.org
Fri Dec 1 00:20:45 PST 2006

The following reply was made to PR misc/106091; it has been noted by GNATS.

From: Ruslan Ermilov <ru at FreeBSD.org>
To: Jed Donnelley <jed at nersc.gov>
Cc: bug-followup at FreeBSD.org
Subject: Re: misc/106091: Keyboard disabled at mountroot> prompt
Date: Fri, 1 Dec 2006 11:17:55 +0300

 Content-Type: text/plain; charset=us-ascii
 Content-Disposition: inline
 Content-Transfer-Encoding: quoted-printable
 On Thu, Nov 30, 2006 at 06:23:39PM -0800, Jed Donnelley wrote:
 > At 06:17 PM 11/30/2006, Ruslan Ermilov <ru at FreeBSD.org>  wrote:
 > >On Thu, Nov 30, 2006 at 08:42:48PM +0000, Jed Donnelley wrote:
 > >> In the process of setting up a gmirror I messed up my fstab.
 > >> When the boot process couldn't find a / to mount it dropped to the:
 > >>
 > >> mountroot>
 > >>
 > >> prompt.  However, I found at that point that keyboard input was not
 > >> accepted.  I ended up having to start a system from a CD in "rescue"
 > >> mode, mount the / file system from the hard drive and edit /etc/fstab
 > >> that way.
 > >
 > >Was it observed over a serial console?
 > No, KVM.  Is there some reason that facility is only available over
 > a serial console?  The output displayed properly on the monitor
 > and of course with a proper boot off a CD or HD the keyboard input
 > worked properly.
 There was a bug in this area when using a serial console which I've
 found and worked around it, hence asking.  I hoped it was with a
 serial console, but now that I reread your post... with a serial
 console it was different -- the input would be accepted but ignored,
 like if you just pressed <Enter> without entring anything.
 Ruslan Ermilov
 ru at FreeBSD.org
 FreeBSD committer
 Content-Type: application/pgp-signature
 Content-Disposition: inline
 Version: GnuPG v1.4.5 (FreeBSD)

More information about the freebsd-bugs mailing list