kern/57042: -current kernel hangs on booting with ata cd-rw device

Tamas R. freddy at
Sat Sep 20 14:40:19 PDT 2003

>Number:         57042
>Category:       kern
>Synopsis:       -current kernel hangs on booting with ata cd-rw device
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Sat Sep 20 14:40:16 PDT 2003
>Originator:     Tamas R.
>Release:        FreeBSD 5.1-CURRENT i386
System: FreeBSD 5.1-CURRENT i386

        Relevant Hardware configuration:
	Motherboard: P4S533-E (CPU: Intel)
	Chipsets: SIS 645DX+ (North Bridge: SIS645DX, South Bridge: SIS962/L)
	CD-Writer: Plextor 48/24/48 (PX-W4824TA)
        Recent 5.x kernel hangs on booting after recognizing the ATA CD-RW
	device (previous kernel compiled on 11/08/03 worked very well). I think
	it is from ATAng changes in kernel, which is mentioned in 'UPDATING'.
	I only attach the relevant booting logs to demonstrate the problem:
	acd0: setting UDMA33 on SiS 962 chip
	acd0: <PLEXTOR CD-R PX-W4824A/1.05> CDRW drive at ata0 as slave
	acd0: read 6890KB/s (6890KB/s) write 8268KB/s (8268KB/s), 4096KB buffer, UDMA33
	acd0: Reads: CDR, CDRW, CDDA stream, packet
	acd0: Writes: CDR, CDRW, test write, burnproof
	acd0: Audio: play, 256 volume levels
	acd0: Mechanism: ejectable tray, unlocked
	acd0: Medium: CD-ROM unknown
	(probe0:ata0:0:0:0): error 22
	(probe0:ata0:0:0:0): Unretryable Error
	ata1: spurious interrupt - status=0x50 error=0x00
	ata0: spurious interrupt - status=0x50 error=0x04
	acd0: WARNING - REQUEST_SENSE recovered from missing interrupt
	At this point the keyboard does not freeze but I can only use the reset
	button to restart the computer.. Booting in safe mode (ATA PIO modes,
	etc) causes the same result.
	I suspect that it is not easy to reproduce this "problem" on other
	hardware configs but I would help to fix it.



More information about the freebsd-bugs mailing list