ng_ubt with Broadcom BCM92035DGL

Maksim Yevmenkin maksim.yevmenkin at
Thu Jan 6 11:25:49 PST 2005

Ronald Klop wrote:


> I commented out this list of hci-commands one by one and they all give 
> the  same error. (Status: Command disallowed [0xc])
> reset
> write_scan_enable 3
> write_class_of_device
> change_local_name

none of the commands above is strictly required. well, maybe with 
exception of 'write_scan_enable 3' command. this command supposed to 
make bluetooth device answer inquiry from the remote devices, i.e. it 
makes bluetooth device 'visible' to other devices.

what is the output of

% hccontrol -n ubt0hci read_node_state
% hccontrol -n ubt0hci read_scan_enable
% hccontrol -n ubt0hci read_class_of_device
% hccontrol -n ubt0hci read_local_name


> After commenting all this rc.bluetooth ends without errors. The output 
> is  this.
> + /usr/sbin/ngctl mkpeer ubt0: hci hook drv
> + /usr/sbin/ngctl name ubt0:hook ubt0hci
> + /usr/sbin/ngctl msg ubt0hci: set_debug 3
> + /usr/sbin/ngctl mkpeer ubt0hci: l2cap acl hci
> + /usr/sbin/ngctl name ubt0hci:acl ubt0l2cap
> + /usr/sbin/ngctl msg ubt0l2cap: set_debug 3
> + /usr/sbin/ngctl connect ubt0hci: btsock_hci_raw: raw ubt0raw
> + /usr/sbin/ngctl connect ubt0l2cap: btsock_l2c_raw: ctl ubt0ctl
> + /usr/sbin/ngctl connect ubt0l2cap: btsock_l2c: l2c ubt0l2c
> + /usr/sbin/hccontrol -n ubt0hci read_bd_addr
> BD_ADDR: 00:02:72:c0:23:12
> + /usr/sbin/hccontrol -n ubt0hci read_local_supported_features
> Features: 0xff 0xff 0xd 0x38 0x8 0x8 00 00
> <3-Slot> <5-Slot> <Encryption> <Slot offset>
> <Timing accuracy> <Switch> <Hold mode> <Sniff mode>
> <Park mode> <RSSI> <Channel quality> <SCO link>
> <HV2 packets> <HV3 packets> <u-law log> <A-law log> <CVSD>
> <Power control> <Transparent SCO data>
> + /usr/sbin/hccontrol -n ubt0hci read_buffer_size
> Max. ACL packet size: 377 bytes
> Number of ACL packets: 10
> Max. SCO packet size: 16 bytes
> Number of SCO packets: 0
> + /usr/sbin/hccontrol -n ubt0hci initialize
> I then tried 'hccontrol -n ubt0hci inquiry', but it returns nothing.
> (I'm trying to connect to my mobile phone.)
> Any thoughts?

the output above looks fine, so i'd say it should work.

- did you enable bluetooth on your phone?

- did you make your phone 'visible' to other bluetooth devices (look 
somewhere under bluetooth security settings)

- what is your phone make and model?


More information about the freebsd-bluetooth mailing list