Proposed addition of malloc_size_np()
jasone at FreeBSD.org
Sun Mar 26 18:04:20 UTC 2006
Robert Watson wrote:
> I wonder if the intuitive objection people are raising is actually with
> the name. Since malloc_size() is defined on at least one platform to
> return the requested size, maybe a name like malloc_allocated_size() (or
> something a bit more compact) would help avoid that confusion, and make
> it clear that the consumer is getting back a commitment and not a hint
> for future realloc(), etc.
Maybe you're right. We could just call it malloc_usable_size() and be
compatible with Linux.
More information about the freebsd-arch