How/why would dev.cpu.0.freq_levels change??!?

Ian Smith smithi at
Mon Jun 30 05:24:52 UTC 2008

On Sun, 29 Jun 2008, David Wolfskill wrote:
 > OK; I've managed to demonstrate a few things:
 > * Stopping powerd before the phenomenon occurs does not prevent
 >   dev.cpu.0.freq_levels from changing, though it does appear to prevent
 >   dev.cpu.0.freq from changing:
 >   g1-60(6.3-S)[1] sysctl dev.cpu.0.freq_levels dev.cpu.0.freq
 >   dev.cpu.0.freq_levels: 1200/0 1050/0 900/0 750/0 600/0 450/0 300/0 150/0
 >   dev.cpu.0.freq: 2400
 >   g1-60(6.3-S)[2] 
 > * As you can see, this can lead to the "interesting" situation that the
 >   current CPU frequency is higher than the maximum "available."

Perhaps just morbid curiousity, but I'm wondering which cpufreq drivers
this machine winds up using (acpi_perf or est/p4tcc or .. ?)

  grep -i acpi /var/run/dmesg.boot ?
  sysctl hw.acpi ?

 > * The phenomenon is not limited to when I run RELENG_6; in an effort to
 >   avoid the continuous fan whine, I tried running RELENG_7 for a while,
 >   and encountered a recurrence rather quickly.  :-(
 > * I tried firing up the Dell diagnostics; they reported OK for each of
 >   the CPU & motherboard fans at high speed, but when the diags tried to
 >   switch to low speed, they reported that the fans only went down (from
 >   10-11K RPM) to about 7K RPM instead of 5K RPM.  (They reported that

10-11K?  Wow.

 >   everything else was working "optimally."  Since their serial port test
 >   is known to be inadequate -- it makes no attempt to actually use the
 >   serial port to send or receive data at all -- I don't know how much that
 >   assessment is actually worth.)
 > I still don't know what the problems are, but it's apparent that
 > something outside FreeBSD's control is misbehaving.  Given that, I
 > suppose it would be unreasonable to expect FreeBSD to compensate
 > in an attempt to enforce rationality.  :-(

Had a quick look at your .asl, doesn't mean much to me, but I wonder

  . are you running the latest BIOS/ACPI upgrade available from Dell?
        "Project: DELL Mojave",
        "Date: 01/28/1998",
        "Ver: 1.00.04"

  . might you have any BIOS settings re performance/economy/cooling set?

  . not running it in a dock are you?

>From what you've described, it almost sounds like a hardware temperature
sensor may have failed, or be reporting wrong, or something .. as this
has only appeared recently, either something's broken, or perhaps you've
inadvertantly changed something?  You did mention having been inside ..
did that go as far as re-pasting the CPU or other heatsinks?

cheers, Ian

More information about the freebsd-acpi mailing list