ASL compilation from Acer 5570z

William william88 at
Tue Jan 22 03:59:32 PST 2008


Some months ago I wrote an email to this mailing list about issues
with my Acer 5570z but I was a little busy to look it more carefully.
The worst problem is about the ethernet:
mskc0: <Marvell Yukon 88E8038 Gigabit Ethernet> irq 16 at device 0.0 on pci2
mskc0: 0x4000 bytes of rid 0x10 res 3 failed (0, 0xffffffff).
mskc0: unknown device: id=0x00, rev=0x00
device_attach: mskc0 attach returned 6

Yesterday I'd take a look in the ASL generated from acpidump -dt and
tried to compile it with iasl and I got 10 messages like this:

-- acpi.asl  8254:                         Name (_T_0, 0x00)
Error    4081 -             Use of reserved word ^  (_T_0)

and 1 like this:acpi.asl  8960:                 Method (WMBD, 3, NotSerialized)
Warning  1086 -                            ^ Not all control paths
return a value (WMBD)

Maybe if I fix this the problem with the ethernet can be solved, right?

Can someone help me to fix it or tell me where I should look?



William Grzybowski
Jabber: william88 at gmail dot com
Curitiba/PR - Brazil

More information about the freebsd-acpi mailing list