No resume on Acer Aspire 5101AWLMi (6.2-RELEASE)

Nate Lawson nate at
Sun Apr 1 20:22:27 UTC 2007

Andrew wrote:
> Anyone...?
> On Mon, 26 Mar 2007 23:08:25 +0000 (UTC), Andrew <aremo at> wrote:
>> Hi all,
>> I'm having trouble waking my AMD64 based laptop after an 'acpiconf -s
>> 3'. This computer runs FreeBSD 6.2-RELEASE for i386 and the very
>> latest BIOS from Acer.
>> The laptop goes to sleep correctly (apparently only when X11 is not
>> running, though) but it will not wake up fully. That is, the HD and
>> fan spin up, LEDs light up, but the screen's backlight stays off and
>> the computer does not react to the commands I type blindly.
>> I've tried setting "debug.acpi.resume_beep" to 1, but it doesn't beep
>> when I try to wake it. I've also tried setting "hw.acpi.reset_video"
>> both to 0 and 1, but no luck both ways.
>> Trying to recompile the output of 'acpidump -t -d' shows no errors,
>> only 7 warnings. Shutdown and reboot work correctly since when I've
>> compiled a stripped-down kernel (no EHCI, no hardware that isn't
>> actually there, nothing but the bare minimum).
>> I don't know what else to try, so any help or advice is welcome!

If you don't get a beep at all, something is hanging before FreeBSD even
gets control.  Try removing extra hardware, compiling out various device
drivers, etc.

STR is very hard to get right given the wide number of BIOS-specific
bugs that we can't even see from the OS.  Add to that the immature state
of many X/display drivers in supporting resume and you can understand
why even Linux, which has 10x the developers and assistance from Intel
employees still has a lot of the same problems.


More information about the freebsd-acpi mailing list