Network doesn't work with acpi enabled

Samuel Moñux smonux at gmail.com
Sun Oct 10 03:25:29 PDT 2004


Hi,

I have recently installed 5.3-Beta7 on a box with a Jetway
motherboard. When acpi is enabled, network doesn't work and console
output shows this message
xl0: watchdog timeout

When its disabled, it seems to work fine. This box was running
5.1-Release some time ago without problems.

I don't know anything about ACPI so I hardly can do anything to fix
it. Any help will be appreciated.

Thanks in advance,
Samuel

(This could be the same problem that is reported as i386/72215)

-- dmesg output (ACPI enabled):
Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.3-BETA7 #0: Sat Oct  2 21:01:00 UTC 2004
    root at wv1u.samsco.home:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel Pentium III (800.03-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x686  Stepping = 6
  Features=0x387f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,PN,MMX,FXSR,SSE>
real memory  = 402587648 (383 MB)
avail memory = 384266240 (366 MB)
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <JETWAY AWRDACPI> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-safe" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x4008-0x400b on acpi0
cpu0: <ACPI CPU (3 Cx states)> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port
0x5000-0x500f,0x4080-0x40ff,0x4000-0x407f,0xcf8-0xcff on acpi0pci0:
<ACPI PCI bus> on pcib0
agp0: <VIA 82C691 (Apollo Pro) host to PCI bridge> mem
0xd0000000-0xd3ffffff at device 0.0 on pci0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <VIA 82C596B UDMA66 controller> port
0xe000-0xe00f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 7.1 on
pci0
ata0: channel #0 on atapci0
ata1: channel #1 on atapci0
uhci0: <VIA 83C572 USB controller> port 0xe400-0xe41f irq 10 at device
7.2 on pci0
uhci0: [GIANT-LOCKED]
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
pci0: <bridge, HOST-PCI> at device 7.3 (no driver attached)
pci0: <multimedia, audio> at device 9.0 (no driver attached)
xl0: <3Com 3c900B-TPO Etherlink XL> port 0xec00-0xec7f mem
0xd9000000-0xd900007f irq 5 at device
15.0 on pci0
xl0: selecting 10baseT transceiver, half duplex
xl0: Ethernet address: 00:04:76:db:19:9f
fdc0: <floppy drive controller> port 0x3f7,0x3f2-0x3f5 irq 6 drq 2 on acpi0
fdc0: [FAST]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0 port 0x3f8-0x3ff irq 4 on acpi0
sio0: type 16550A
sio1 port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
ppc0 port 0x778-0x77b,0x378-0x37f irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/16 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> flags 0x24 irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model 4D+ Mouse, device ID 8
orm0: <ISA Option ROM> at iomem 0xc0000-0xcffff on isa0
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 800033774 Hz quality 800
Timecounters tick every 10.000 msec
acpi_cpu: throttling enabled, 2 steps (100% to 50.0%), currently 100.0%
ad0: 19092MB <WDC WD200EB-00BHF0/15.15M15> [38792/16/63] at ata0-master UDMA66
ad1: 57241MB <ST360021A/3.19> [116301/16/63] at ata0-slave UDMA66
acd0: CDROM <ATAPI-CD ROM-DRIVE-50MAX/VER 50NT> at ata1-master UDMA33
acd1: CDRW <PCRW804/2,0> at ata1-slave PIO4
Mounting root from ufs:/dev/ad1s3a

-- acpidump -t output:

/*
  RSD PTR: OEM=JETWAY, ACPI_Rev=1.0x (0)
        RSDT=0x17ff3000, cksum=199
 */
/*
  RSDT: Length=40, Revision=1, Checksum=246,
        OEMID=JETWAY, OEM Table ID=AWRDACPI, OEM Revision=0x42302e31,
        Creator ID=AWRD, Creator Revision=0x0
        Entries={ 0x17ff3040 }
 */
/*
  FACP: Length=116, Revision=1, Checksum=36,
        OEMID=JETWAY, OEM Table ID=AWRDACPI, OEM Revision=0x42302e31,
        Creator ID=AWRD, Creator Revision=0x0
        FACS=0x17ff0000, DSDT=0x17ff30c0
        INT_MODEL=PIC
        Preferred_PM_Profile=Unspecified (0)
        SCI_INT=9
        SMI_CMD=0x402f, ACPI_ENABLE=0xa1, ACPI_DISABLE=0xa0, S4BIOS_REQ=0x0
        PSTATE_CNT=0x0
        PM1a_EVT_BLK=0x4000-0x4003
        PM1a_CNT_BLK=0x40f0-0x40f1
        PM_TMR_BLK=0x4008-0x400b
        GPE0_BLK=0x4020-0x4023
        P_LVL2_LAT=90 us, P_LVL3_LAT=900 us
        FLUSH_SIZE=0, FLUSH_STRIDE=0
        DUTY_OFFSET=0, DUTY_WIDTH=1
        DAY_ALRM=125, MON_ALRM=126, CENTURY=50
        IAPC_BOOT_ARCH=
        Flags={WBINVD,PROC_C1,SLP_BUTTON}
 */
/*
  FACS: Length=64, HwSig=0x00000000, Firm_Wake_Vec=0x00000000
        Global_Lock=
        Flags=S4BIOS
        Version=0
 */
/*
  DSDT: Length=9556, Revision=1, Checksum=68,
        OEMID=JETWAY, OEM Table ID=AWRDACPI, OEM Revision=0x1000,
        Creator ID=MSFT, Creator Revision=0x100000c
 */

-- sysctl hw.acpi
hw.acpi.supported_sleep_state: S1 S5
hw.acpi.power_button_state: S5
hw.acpi.sleep_button_state: S1
hw.acpi.lid_switch_state: NONE
hw.acpi.standby_state: S1
hw.acpi.suspend_state: S3
hw.acpi.sleep_delay: 1
hw.acpi.s4bios: 1
hw.acpi.verbose: 0
hw.acpi.reset_video: 1
hw.acpi.cpu.throttle_max: 2
hw.acpi.cpu.throttle_state: 2
hw.acpi.cpu.cx_supported: C1/0 C2/90
hw.acpi.cpu.cx_lowest: C1
hw.acpi.cpu.cx_usage: 100.00% 0.00%
hw.acpi.thermal.min_runtime: 0
hw.acpi.thermal.polling_rate: 10
hw.acpi.thermal.tz0.temperature: 2950
hw.acpi.thermal.tz0.active: -1
hw.acpi.thermal.tz0.thermal_flags: 0
hw.acpi.thermal.tz0._PSV: 3232
hw.acpi.thermal.tz0._HOT: -1
hw.acpi.thermal.tz0._CRT: 3332
hw.acpi.thermal.tz0._ACx: 3232 -1 -1 -1 -1 -1 -1 -1 -1 -1


More information about the freebsd-acpi mailing list