ACPI is not working

Christian Uhrhan christian.uhrhan at
Tue May 4 13:32:42 PDT 2004


first of all: sorry for my english its not my native language.

system details:
Notebook:       targa visionary xp
CPU:            mobile amd athlon 2200+
uname -a:       FreeBSD 5.2-CURRENT FreeBSD
5.2-CURRENT #0:
                Sun May  2 12:45:35 CEST 2004
chris at  i386

dmesg output:
sysctl hw.acpi:

first i had installed freebsd 5.1 but got some errors about a broken
acpi-table. After installing
freebsd 5.2 the errors there was no more errors at boot-time but acpi was
still not working. so
first of all i ask google about acpi and freebsd and the first things which
was noticeable to me
was a message which does not appear at my boot output, like this:

acpi_cpu: throttling enabled, 8 steps (100% to 12.5%)

furthermore or better said therefore my system is mission sysctl-variables

hw.acpi.cpu.performance oder

i googled again but could not find a reason for this behavior and it seems
to me a little bit
strangely because i know to 100% that cpu throttling is supported by my cpu
and it is working
fine under windows (i know windows does't take it so exactly with acpi
standard so it isn't
realy a good comparison).

after the google session i posted the problem in a german freebsd-forum
( but
nobody could help me. so i decided to update the system to 5.2-current to
get the lastest
source and to see if acpi is working with it. when the update finished i
rebooted and after
login the cpu-cooler got slowed down in his speed but after a few seconds it
came back to
full speed. first i examined the output of dmesg and again the lines like
(1) does not appear
and therefore there was no sysctl-variable like (2).

so i thought i could download a knoppix-with-acpi-version and look if acpi
is working there.
i did it and realy the cpu-cooler got slowed down and came only up to full
speed when i was
doing some cpu intensive operations. i dumped the /proc/acpi/dsdt content to
a file and
rebooted the system. next i did a iasl -dc <dsdt_file> and copied it to
/boot. then i modified
the loader.conf to this:


after this i rebooted the system and i got the message that the acpi table
was overwritten
by the OS. but it brought no success. i looked at the freebsd-handbook and
found out that
it could fix some problems by define the variable acpi_osname and i tried it
out by setting

acpi_osname="Microsoft Windows NT"

because this string was in the decoded dsdt-file.

so now i don't know what i could do anymore and i post it to this

are there any possibilities i did not thought about?

sorry for the long post and i hope my english is good enough so you
understand the problem.

yours sincerely

NEU : GMX Internet.FreeDSL
Ab sofort DSL-Tarif ohne Grundgebühr:

More information about the freebsd-acpi mailing list