ACPI broken on Acer TravelMate 4200WLMi - call for help

security at security at
Sun Dec 26 22:31:18 PST 2004

APM doesn't work either :(

I tried first with APM, there is no /dev/apmctl device and 'apm' shows the
same output.

The only thing I could achieve with APM instead of ACPI was having estctrl
properly lowering/increasing my pentium-m clock speed according to the
system load.

I tried apm_enable and apmd_enable (which complains of no /dev/apmctl),
same hints as I described in the last mail, except enabling apm and
disabling ACPI, and I did compile APM in the kernel when I tried APM.

Did I miss something in order to make APM work?

It kinda sucks to run the laptop without the battery info, I've already
let it run out of battery 2 times because I couldn't tell.. I can't be
looking to the battery light (on the front) all the time :/

APM instead of ACPI for now would do just fine, but I can't seem to make
it work either.. Do you have any suggestions I could use here ?

btw, I don't know if this is a known bug, but with ACPI on, 'top' displays
completely wrong values for CPU usage. I was compiling firefox,
thunderbird and something else and it showed no more than 0.20% CPU as the
most cpu-eater process. With ACPI turned off the values are correctly

If there is something I can do to help improving APM/ACPI on this laptop
model, please contact me.



> security at wrote:
>> Hey list,
>> I'm writing to report a but with FreeBSD's ACPI implementation. Recently,
>> I've acquired an Acer TravelMate 4200WLMi laptop, on which I've installed
>> FreeBSD 5.3-RELEASE.
>> I've been struggling with a problem for two days, and can't seem to get
past it.
>> I've been a FreeBSD user for many years now, so I've done everything I
could remember of. But, as I'm new to FreeBSD on laptops, I thought I
could have missed something. I no longer think I've missed a step, as
>> tried pretty much everything I know of.
>> The problem is the following: I can't get FreeBSD's ACPI implementation to
>> show my battery status! This implies I don't have any power management
functions available.
>> I know ACPI works because the laptop shipped with windows. While I
promptly sent it away, before doing so, I installed a game
(Wolfenstein: Enemy Territory) to see 3D performance. The battery icon
on windows XP was
>> showing correct battery info.
> Sorry, this is a lack of support problem.  Modern ACER laptops have a
different kind of battery system (called "smart battery" in the ACPI
spec) that is accessed via SMbus.  Both FreeBSD and Linux do not support
this yet.
> I'd be happy if someone picked up the task of implementing it.  It's
pretty big but is already recorded on the ACPI web page:
> You can use apm for now.
> --
> Nate

More information about the freebsd-acpi mailing list