ACPI broken on Acer TravelMate 4200WLMi - call for help

security at security at
Sun Dec 26 21:20:08 PST 2004

Hey list,

I'm writing to report a but with FreeBSD's ACPI implementation. Recently,
I've acquired an Acer TravelMate 4200WLMi laptop, on which I've installed

I've been struggling with a problem for two days, and can't seem to get
past it.

I've been a FreeBSD user for many years now, so I've done everything I
could remember of. But, as I'm new to FreeBSD on laptops, I thought I
could have missed something. I no longer think I've missed a step, as I've
tried pretty much everything I know of.

The problem is the following: I can't get FreeBSD's ACPI implementation to
show my battery status! This implies I don't have any power management
functions available.

I know ACPI works because the laptop shipped with windows. While I
promptly sent it away, before doing so, I installed a game (Wolfenstein:
Enemy Territory) to see 3D performance. The battery icon on windows XP was
showing correct battery info.

Here is what I get with FreeBSD:

# apm
APM version: 1.2
APM Management: Enabled
AC Line status: unknown
Battery Status: charging
Remaining battery life: invalid value (0xffffffff)
Remaining battery time: unknown
Number of batteries: 0
Resume timer: unknown
Resume on ring indicator: disabled

Weird. It says it's charging, at this very moment it isn't.

# acpiconf -i0
acpiconf: get battery info (0) failed: Device not configured

No battery detected! (this is my problem)

I know ACPI is enabled:

# kldstat
Id Refs Address    Size     Name
 1   12 0xc0400000 57c80c   kernel
 2   14 0xc097d000 537f0    acpi.ko
 3    1 0xc1f04000 17000    linux.ko
 4    1 0xc1f58000 9000     if_iwi.ko
 5    1 0xc1fb7000 5000     snd_ich.ko
 6    1 0xc1fbc000 18000    sound.ko

And I have correct /boot/device.hints entries:

# head /boot/device.hints
# $FreeBSD: src/sys/i386/conf/GENERIC.hints,v 1.13 2004/04/01 21:48:31
alfred Exp $

The system is a 5.3-RELEASE with a custom kernel:

# uname -a
FreeBSD 5.3-RELEASE FreeBSD 5.3-RELEASE #2: Sun Dec
26 07:50:44 WET 2004    
hugo at  i386

At this moment, kernel had neither acpi nor apm compiled in.
I've tried acpi+apm, apm only, acpi only, but then I read somewhere it
would be easier to have acpi as a module for testing purposes. The kernel
does not have apm or acpi compiled in, at this moment.

Suspending also screws up, but this might be related to the batteries not
showing up. Sending it to sleep with acpiconf -s will blank the screen,
but when I wake it up, the screen remains black.

Here is sysctl -a hw.acpi.

hw.acpi.supported_sleep_state: S3 S4 S5
hw.acpi.power_button_state: S5
hw.acpi.sleep_button_state: S3
hw.acpi.lid_switch_state: NONE
hw.acpi.standby_state: S1
hw.acpi.suspend_state: S3
hw.acpi.sleep_delay: 1
hw.acpi.s4bios: 0
hw.acpi.verbose: 1
hw.acpi.reset_video: 1
hw.acpi.cpu.throttle_max: 8
hw.acpi.cpu.throttle_state: 1
hw.acpi.cpu.cx_supported: C1/0 C2/1 C3/85
hw.acpi.cpu.cx_lowest: C1
hw.acpi.cpu.cx_usage: 100.00% 0.00% 0.00%
hw.acpi.thermal.min_runtime: 0
hw.acpi.thermal.polling_rate: 10
hw.acpi.thermal.tz0.temperature: 3252 -1
hw.acpi.thermal.tz0.thermal_flags: 0
hw.acpi.thermal.tz0._PSV: 3652
hw.acpi.thermal.tz0._HOT: -1
hw.acpi.thermal.tz0._CRT: 3732
hw.acpi.thermal.tz0._ACx: 3462 3392 -1 -1 -1 -1 -1 -1 -1 -1

My ASL is here:

And a dmesg -v at:

(I'll be uploading within the next 10 minutes)

As a last note, there is a new BIOS version available for my system, but
I'd prefer not to flash as I've had bad experiences doing this. Also,
their utility is for windows only, and FreeBSD is the only soul alive here

Anything I can test to make this work I will.. please, do report back

Thanks for reading so far!



More information about the freebsd-acpi mailing list