cvs commit: src/sys/boot/common ufsread.c
M. Warner Losh
imp at bsdimp.com
Fri Oct 26 09:00:02 PDT 2007
In message: <200710261136.54938.jhb at freebsd.org>
John Baldwin <jhb at FreeBSD.org> writes:
: On Friday 26 October 2007 11:00:34 am Warner Losh wrote:
: > imp 2007-10-26 15:00:34 UTC
: > FreeBSD src repository
: > Modified files:
: > sys/boot/common ufsread.c
: > Log:
: > The arm boot code uses this function as well. Redefining cgbase()
: > saves about 500 bytes in the boot code. While the AT91RM9200 has 12k
: > of space for the boot loader, which is more than i386's 8k, the code
: > generated by gcc is a bit bigger.
: > I've had this in p4 for about two years now.
: > Revision Changes Path
: > 1.16 +1 -1 src/sys/boot/common/ufsread.c
: We should probably change this to be #ifdef SMALL_CGBASE or some such then and
: just define it before ufsread.c in boot2.c and other files that include it.
: Does that sound ok to you (or do you have a better name?) UFS_SMALL_CGBASE
I can't think of a better name, but that does sound good to me. It
would also allow finer granularity of control for these things.
One thing I'm unsure about is the amd64 boot blocks. Do those get
build -D__i386__? Are they just the i386 boot blocks because amd64
boxes boot in the same old mode than 32-bit x86 boxes boot?
More information about the cvs-src