[FreeBSD-CVS] cvs commit: src/sys/dev/twa twa_cam.c twa_globals.c twa_ioctl.h

Ralf S. Engelschall rse at FreeBSD.org
Fri Feb 11 19:27:52 GMT 2005

On Fri, Feb 11, 2005, Vinod Kashyap wrote:

> > The same problem (3ware controller found, but device /dev/daX not
> > discovered on booting and hence no root mount point) popped up for
> > me yesterday under RELENG_5, too. The problem can be traced back to
> > changes between 2005-02-03 (date of my old still working kernel) and
> > 2005-02-10 (date of my new broken kernel). The whole diff to sys/
> > of RELENG_5 is about 350 KB (I used "cvs diff -jRELENG_5:2005-02-03
> > -jRELENG_5:2005-02-10") and I was at least able to reduce the
> > origin of
> > the problem to the appended 29 KB change set.
> >
> > With the latest RELENG_5 as of 2005-02-11 (today) but with
> > this appended
> > patch again backed out, the twa(4) problem is solved, too. Similarily,
> > if I do not back out those changes and just use plain RELENG_5 as of
> > 2005-02-11 with your patch above applied it is also solved.
> >
> > I guess your patch workarounds the problem, but the real origin of the
> > problem is somewhere in the changes we can see in the appended patch.
> > Unfortunately I do not understand the side-effects of those
> > changes so I
> > was not able to figure out myself which part of the change is actually
> > causing the trouble for the twa(4) driver.
> >
> > Perhaps someone else can jump in and fix the origin of the problem...
> But the problem was first reported with RELENG_5 on Jan 12th, '05.
> And I couldn't find any CAM related changes in the patch you sent.

Yes, I know. Even the CAM related change between 2005-02-03 and
2005-02-11 had no effect on the problem. And I also recognized that
people started to see problems before 2005-02-03.

> The thing is, the occurrence of this seems to be pretty inconsistent.
> I have never seen the problem myself at boot time, although I have
> seen CAM not send down inquiries some times, on doing a kldload of
> the driver (without my latest patch).

My twa(4) was static in the kernel, btw. The question for me now mainly
is: why do the backing out of the changes I sent also fix the problem...

rse at FreeBSD.org                        Ralf S. Engelschall
FreeBSD.org/~rse                       rse at engelschall.com
FreeBSD committer                      www.engelschall.com

More information about the cvs-src mailing list