cvs commit: src/sys/dev/vge if_vge.c

Bill Paul wpaul at FreeBSD.ORG
Mon Apr 25 19:44:35 PDT 2005

> Bill Paul wrote:
> >>with this change, I got following error on my abit av8:
> >>vge0: <VIA Networking Gigabit Ethernet> port 0xb800-0xb8ff mem 
> >>0xf8122000-0xf81220ff irq 22 at device 14.0 on pci0
> >>vge0: MII read timed out
> >>vge0: failed to start MII autopoll
> >>vge0: MII without any phy!
> >>device_attach: vge0 attach returned 6
> >>    
> >>
> >
> >Fine, I took the reload step out. This should fix it. (If reading
> >the RX filter registers instead of the EEPROM makes it mad, then
> >I'll scream.)
> > 
> >  
> >
> With your lastest change, I still get same error result.

I don't believe you. There's no reason why not reading the EEPROM
would break it. Especially since it doesn't break my sample card.
Whatever your problem is, I'm not even going to try to fix it without
access to the hardware, so I guess you just lose.

> >It must not be that important to you since you never bothered to mention
> >this to anyone before.
> >
> >Given all the various things it's complaining about when it fails,
> >it looks like the driver is no longer able to communicate with the device
> >over the PCI bus. All register accesses are failing. This may not be a
> >problem with the driver per-se, but with the PCI bridge. It might be
> >the device has completely locked up, but if vge_reset() doesn't bring
> >it back to life, then I don't know what else to do.
> >
> >  
> >
> Without recent change, I can kldunload and kldload it to bring it back 
> to work.

*sigh* Is there some reason you didn't feel like telling me this the
first time? Why can't people just give me all the information up front
instead of making me drag it out of them. Is it so hard? Do I fix the
bugs by checking in one line of code at a time? No. So why do people
only describe their problems one line at a time?


More information about the cvs-src mailing list