cvs commit: src/sys/kern kern_descrip.c vfs_lookup.c vfs_syscalls.c src/sys/sys syscallsubr.h

Paul Saab ps at FreeBSD.org
Sat Apr 23 14:53:05 PDT 2005


ps          2005-04-23 21:53:05 UTC

  FreeBSD src repository

  Modified files:        (Branch: RELENG_5)
    sys/kern             kern_descrip.c vfs_lookup.c 
                         vfs_syscalls.c 
    sys/sys              syscallsubr.h 
  Log:
  MFC:
  
  - Implement kern_foo wrappers for stat(), lstat(), fstat(), statfs(),
    fstatfs(), and fhstatfs().  Use these wrappers to cut out a lot of
    code duplication for freebsd4 and netbsd compatability system calls.
  - Add a new lookup function kern_alternate_path() that looks up a filename
    under an alternate prefix and determines which filename should be used.
    This is basically a more general version of linux_emul_convpath() that
    can be shared by all the ABIs thus allowing for further reduction of
    code duplication.
  
  Revision   Changes    Path
  1.243.2.7  +17 -19    src/sys/kern/kern_descrip.c
  1.64.2.2   +113 -0    src/sys/kern/vfs_lookup.c
  1.356.2.3  +96 -115   src/sys/kern/vfs_syscalls.c
  1.11.2.9   +15 -0     src/sys/sys/syscallsubr.h


More information about the cvs-src mailing list