cvs commit: src/sys/kern kern_prot.c src/sys/sys systm.h
jhb at FreeBSD.org
Mon Jul 19 06:24:54 PDT 2004
On Friday 16 July 2004 05:44 pm, Colin Percival wrote:
> At 12:42 16/07/2004, John Baldwin wrote:
> >On Friday 16 July 2004 11:57 am, Colin Percival wrote:
> >> Log:
> >> Add a SUSER_RUID flag to suser_cred. This flag indicates that we want
> >> to check if the *real* user is the superuser (vs. the normal behaviour,
> >> which checks the effective user).
> >Could we rename PRISON_ROOT to SUSER_PRISONOK or some such to be
> > consistent?
> I'd be happy to do this; should I simply add the new name, or should I
> make the substitution across the entire tree?
I would ask Robert's opinion. :) I would vote for adding the new name and
changing it across the tree and add in a #define for the old name that is
inside #ifdef OBSOLETE_IN_6 or some such so it is deprecated for 5.x and gone
John Baldwin <jhb at FreeBSD.org> <>< http://www.FreeBSD.org/~jhb/
"Power Users Use the Power to Serve" = http://www.FreeBSD.org
More information about the cvs-src