cvs commit: src/sys/vm uma_core.c uma_int.h

Jeff Roberson jeff at FreeBSD.org
Thu Sep 18 23:27:01 PDT 2003


jeff        2003/09/18 23:26:47 PDT

  FreeBSD src repository

  Modified files:
    sys/vm               uma_core.c uma_int.h 
  Log:
   - Initialize a pool of bucket zones so that we waste less space on zones that
     don't cache as many items.
   - Introduce the bucket_alloc(), bucket_free() functions to wrap bucket
     allocation.  These functions select the appropriate bucket zone to
     allocate from or free to.
   - Rename ub_ptr to ub_cnt to reflect a change in its use.  ub_cnt now reflects
     the count of free items in the bucket.  This gets rid of many unnatural
     subtractions by 1 throughout the code.
   - Add ub_entries which reflects the number of entries possibly held in a
     bucket.
  
  Revision  Changes    Path
  1.75      +139 -75   src/sys/vm/uma_core.c
  1.18      +3 -10     src/sys/vm/uma_int.h


More information about the cvs-src mailing list