cvs commit: src/sys/dev/atkbdc atkbd.c atkbd_atkbdc.c src/sys/dev/kbd kbd.c kbdreg.h src/sys/dev/kbdmux kbdmux.c src/sys/dev/syscons syscons.c syscons.h src/sys/dev/usb ukbd.c src/sys/dev/vkbd vkbd.c

Wojciech A. Koszek wkoszek at
Sat Dec 29 21:55:26 UTC 2007

wkoszek     2007-12-29 21:55:25 UTC

  FreeBSD src repository

  Modified files:
    sys/dev/atkbdc       atkbd.c atkbd_atkbdc.c 
    sys/dev/kbd          kbd.c kbdreg.h 
    sys/dev/kbdmux       kbdmux.c 
    sys/dev/syscons      syscons.c syscons.h 
    sys/dev/usb          ukbd.c 
    sys/dev/vkbd         vkbd.c 
  Remove explicit calls to keyboard methods with their respective variants
  implemented with macros. This patch improves code readability. Reasoning
  behind kbdd_* is a "keyboard discipline".
  List of macros is supposed to be complete--all methods of keyboard_switch
  should have their respective macros from now on.
  Functionally, this code should be no-op. My intention is to leave current
  behaviour of code as is.
  Glanced at by:  rwatson
  Reviewed by:    emax, marcel
  Approved by:    cognet
  Revision  Changes    Path
  1.53      +4 -4      src/sys/dev/atkbdc/atkbd.c
  1.21      +4 -4      src/sys/dev/atkbdc/atkbd_atkbdc.c
  1.47      +12 -17    src/sys/dev/kbd/kbd.c
  1.19      +44 -0     src/sys/dev/kbd/kbdreg.h
  1.16      +14 -35    src/sys/dev/kbdmux/kbdmux.c
  1.455     +28 -28    src/sys/dev/syscons/syscons.c
  1.89      +0 -20     src/sys/dev/syscons/syscons.h
  1.76      +5 -5      src/sys/dev/usb/ukbd.c
  1.12      +4 -5      src/sys/dev/vkbd/vkbd.c

More information about the cvs-all mailing list