cvs commit: src/sys/dev/acpica/Osd OsdTable.c src/sys/sys
kernel.h src/sys/boot/forth loader.conf.5 src/share/man/man4 acpi.4
Guido van Rooij
guido at gvr.org
Wed Feb 18 02:33:15 PST 2004
On Mon, Feb 16, 2004 at 11:52:44AM -0500, John Baldwin wrote:
> On Friday 13 February 2004 10:17 pm, Nate Lawson wrote:
> > njl 2004/02/13 19:17:30 PST
> > FreeBSD src repository
> > Modified files:
> > sys/dev/acpica/Osd OsdTable.c
> > sys/sys kernel.h
> > sys/boot/forth loader.conf.5
> > share/man/man4 acpi.4
> > Log:
> > Fix hw.acpi.os_name by renaming it to hw.acpi.osname. The "_name" suffix
> > is reserved by the loader, and thus any tunable name with that suffix
> > will be silently discarded.
> > Document this in the header and man page so that other developers do not
> > develop so many bumps on the head after banging it against the wall.
> > Detective work by: Mark Santcroos, grehan
> Aha, cute. Note that _load, _before, _after, _type, _flags, and _error are
> also "magic".
As are flags starting with "hint" that do not have a certain sysntax.
In that case the kernel silently renames them to "Hint".
More information about the cvs-all