cvs commit: ports/emulators/linux-ePSXe Makefile

Trevor Johnson trevor at jpj.net
Tue Feb 17 11:21:26 PST 2004


> > From
> > <URL:http://bento.freebsd.org/errorlogs/i386-4-latest/linux-epsxe-1.6.0.log>
> > it looks like the problem is that bento is doing a pkg_add of a linux-gtk
> > package which has a dependency on linux_base 7.1.  In my experience, the
> > linux-gtk port works fine with either linux_base 7.1 or linux_base 8.0.
> > I marked the linux_base 8.0 port RESTRICTED, so most users won't be
> > installing it from a package.  I think that really very few users would
> > suffer from this problem.  A solution would be to include the GTK+ library
> > in the linux_base 7.1 port/package, like I did with linux_base 6.1.  That
> > was unpopular.
>
> The default linux_base package is currently still 7.1, so maybe
> linux-gtk should default to depend on that.

It does; that is part of the problem.

> We can't make 8.0 the
> default linux_base as long as it's restricted anyway (think CD
> installs).

Changing the default linux_base won't help.

> > If this port is removed, the problem will still remain.  There are other
> > ports, and unported software, that are affected.  Maybe
> > MANUAL_PACKAGE_BUILD would be a decent workaround.
>
> I'm less happy with that workaround..there should be a way to solve
> this properly.

Including the GTK+ library in the linux_base 7.1 port/package, as I
suggested, is a proper way to solve it.  Another would be to enhance the
packaging utilities so they can parse information like "linux-gtk port
works fine with either linux_base 7.1 or linux_base 8.0".  NetBSD has this
capability.
-- 
Trevor Johnson


More information about the cvs-all mailing list