2940UW; cannot use disk

Philippe MICHEL phm at tpgnet.net
Mon Dec 14 12:52:57 PST 1998


Hello,

I recently changed the motherboard to an Asus P5A, and added an 2940-UW with
which I had many problems on my old motherboard. I connected a CD-writer,
a CD-Rom and an HP-T4 tape. Anywhere, evethings seams to work well since
I changed to the new P5A.

My Linux kernel version is 2.0.26,
The aic7xxx= 5.1.4 plus the little patch written in the mail-list some days
ago.

So, because I become optimistics, I decided to connected an IBM SCSI-UW disk.
I formatted it, initialized it with fdisk, but with mke2fs the first bloc
seams to be bad.

   droopy:~# mke2fs -c /dev/sdb2 -b 4096
   mke2fs 1.10, 24-Apr-97 for EXT2 FS 0.5b, 95/08/09
   Linux ext2 filesystem format
   Filesystem label=
   713152 inodes, 712884 blocks
   35644 blocks (5.00%) reserved for the super user
   First data block=0
   Block size=4096 (log=2)
   Fragment size=4096 (log=2)
   22 block groups
   32768 blocks per group, 32768 fragments per group
   32416 inodes per group
   Superblock backups stored on blocks:
           32768, 65536, 98304, 131072, 163840, 196608, 229376, 262144, 294912,
           327680, 360448, 393216, 425984, 458752, 491520, 524288, 557056, 589824,
           622592, 655360, 688128
   
   Checking for bad blocks (read-only test): done
   Block 0 in primary superblock/group descriptor area bad.
   Blocks 0 through 2 must be good in order to build a filesystem.
   Aborting....  


But this happens even if I change the fdisk configuration. Low level
format tells no errors. I am suspecting the driver.

I would be ready to believe that the disk has bad blocks, if I had not
so much problems with the SCSI adaptec, in the near past !

Anybody a suggestion ?
Below, the boot message of the aic7xxx module.

please help,
many thanks,


-- 
-
- Ph.MICHEL
- phm at tpgnet.net
-


klogd 1.3-0, log source = /proc/kmsg started.
<4>pcibios_init : PCI BIOS revision 2.10 entry at 0xf0560
<4>Probing PCI hardware.
<4>Calibrating delay loop.. ok - 599.65 BogoMIPS
<4>aha152x: processing commandline: ok
<4>aha152x: BIOS test: passed, detected 1 controller(s)
<4>aha152x0: vital data: PORTBASE=0x340, IRQ=11, SCSI ID=3, reconnect=enabled, parity=enabled, synchronous=disabled, delay=100, extended translation=disabled
<4>aha152x: trying software interrupt, ok.
<4>scsi0 : Adaptec 152x SCSI driver; $Revision: 1.18 $
<4>scsi : 1 host.
<4>  Vendor: IOMEGA    Model: ZIP 100           Rev: J.02
<4>  Type:   Direct-Access                      ANSI SCSI revision: 02
<4>Detected scsi removable disk sda at scsi0, channel 0, id 5, lun 0
<4>scsi : detected 1 SCSI disk total.
<4>SCSI device sda: hdwr sector= 512 bytes. Sectors= 196608 [96 MB] [0.1 GB]
<4>sda: Write Protect is off
<6>(scsi1) <Adaptec AHA-294X Ultra SCSI host adapter> found at PCI 10/0
<6>(scsi1) Wide Channel, SCSI ID=7, 16/255 SCBs
<6>(scsi1) Warning - detected auto-termination
<6>(scsi1) Cables present (Int-50 YES, Int-68 YES, Ext-68 NO)
<6>(scsi1) Downloading sequencer code... 419 instructions downloaded
<4>scsi1 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.4/3.2.4
<4>       <Adaptec AHA-294X Ultra SCSI host adapter>
<4>scsi : 2 hosts.
<4>  Vendor: HP        Model: T4000s            Rev: 1.10
<4>  Type:   Sequential-Access                  ANSI SCSI revision: 02
<4>  Vendor: PLEXTOR   Model: CD-R   PX-R412C   Rev: 1.04
<4>  Type:   CD-ROM                             ANSI SCSI revision: 02
<4>  Vendor: PIONEER   Model: CD-ROM DR-U12X    Rev: 1.04
<4>  Type:   CD-ROM                             ANSI SCSI revision: 02
<4>  Vendor: IBM       Model: DDRS-34560W       Rev: S97B
<4>  Type:   Direct-Access                      ANSI SCSI revision: 02
<4>Detected scsi disk sdb at scsi1, channel 0, id 6, lun 0
<6>(scsi1:0:6:0) Synchronous at 20.0 Mbyte/sec, offset 8.
<4>SCSI device sdb: hdwr sector= 512 bytes. Sectors= 8925000 [4357 MB] [4.4 GB]
<4> sdb: unknown partition table
<4>SCSI device sdb: hdwr sector= 512 bytes. Sectors= 8925000 [4357 MB] [4.4 GB]
<4> sdb: sdb1
<4>SCSI device sdb: hdwr sector= 512 bytes. Sectors= 8925000 [4357 MB] [4.4 GB]
<4> sdb: sdb1
<4>scsi : 1 host.
<6>(scsi1) <Adaptec AHA-294X Ultra SCSI host adapter> found at PCI 10/0
<6>(scsi1) Wide Channel, SCSI ID=7, 16/255 SCBs
<6>(scsi1) Warning - detected auto-termination
<6>(scsi1) Cables present (Int-50 YES, Int-68 YES, Ext-68 NO)
<6>(scsi1) Downloading sequencer code... 419 instructions downloaded
<4>scsi1 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.4/3.2.4
<4>       <Adaptec AHA-294X Ultra SCSI host adapter>
<4>scsi : 2 hosts.
<4>  Vendor: HP        Model: T4000s            Rev: 1.10
<4>  Type:   Sequential-Access                  ANSI SCSI revision: 02
<4>  Vendor: PLEXTOR   Model: CD-R   PX-R412C   Rev: 1.04
<4>  Type:   CD-ROM                             ANSI SCSI revision: 02
<4>  Vendor: PIONEER   Model: CD-ROM DR-U12X    Rev: 1.04
<4>  Type:   CD-ROM                             ANSI SCSI revision: 02
<4>  Vendor: IBM       Model: DDRS-34560W       Rev: S97B
<4>  Type:   Direct-Access                      ANSI SCSI revision: 02
<4>Detected scsi disk sdb at scsi1, channel 0, id 6, lun 0
<6>(scsi1:0:6:0) Synchronous at 20.0 Mbyte/sec, offset 8.
<4>SCSI device sdb: hdwr sector= 512 bytes. Sectors= 8925000 [4357 MB] [4.4 GB]
<4> sdb: sdb1
<4>VFS: Can't find an ext2 filesystem on dev 08:11.
<4>SCSI device sdb: hdwr sector= 512 bytes. Sectors= 8925000 [4357 MB] [4.4 GB]
<4> sdb: sdb1 sdb2
<4>SCSI device sdb: hdwr sector= 512 bytes. Sectors= 8925000 [4357 MB] [4.4 GB]
<4> sdb: sdb1 sdb2
<4>SCSI device sdb: hdwr sector= 512 bytes. Sectors= 8925000 [4357 MB] [4.4 GB]
<4> sdb: sdb1 sdb2
<4>SCSI device sdb: hdwr sector= 512 bytes. Sectors= 8925000 [4357 MB] [4.4 GB]
<4> sdb: sdb1 sdb2
<6>Detected scsi tape st0 at scsi1, channel 0, id 1, lun 0

To Unsubscribe: send mail to majordomo at FreeBSD.org
with "unsubscribe aic7xxx" in the body of the message



More information about the aic7xxx mailing list